• Register so you can experience the greatest RPG server ever! Use the keyword "Herocraft" when registering!Register! Enjoy the server @ play.hc.to !
  • Guest, Make sure to use our LAUNCHER! Read more here!

How To Installing 1.7.2 - Rei's Minimap, Macromod, Liteloader, TABBYCHAT and Optifine

Joined
Aug 30, 2011
Likes
1
Location
Canada
#43
I'm doing this on windows 7, I followed your instructions and the instructions from the guy who made the macromod and liteloader (To install the MacroMod), but for some reason when I launch minecraft using the 'LiteLoader 1.7.10' profile, it says that there are '0 mods installed'. Yes, Macromod is inside the '1.7.10' folder in the 'mods' folder. It's the only one in there. LiteLoader managed to install successfully, but Macromod doesn't want to install... help?

EDIT: Wait, do I have to delete the META-inf folder? Or is that just for Rei's and Optifine? I'm so confused
EDIT 2: Deleted the META.inf folder, nothing happened.
EDIT 3: I also have forge, and I can't help but notice that LiteLoader didn't see that it was installed.
 
Last edited:
Joined
Sep 24, 2012
Likes
33
Location
Paragon, Bastion
#44
Hello! I have an error if anyone cares to look at it, I'll post it in the spoiler below.

Everything was going great until I added Rei's Minimap (Not sure why but I felt like a rebel and added it in last.)

---- Minecraft Crash Report ----
// Oops.

Time: 8/17/14 7:17 AM
Description: Initializing game

java.lang.NoClassDefFoundError: bah
at azd.Z(MinecraftOverlay.java:463)
at azd.e(MinecraftOverlay.java:689)
at net.minecraft.client.main.Main.main(SourceFile:103)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at net.minecraft.launchwrapper.Launch.launch(Launch.java:134)
at net.minecraft.launchwrapper.Launch.main(Launch.java:28)
Caused by: java.lang.ClassNotFoundException: bah
at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:99)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
... 9 more


A detailed walkthrough of the error, its code path and all known details is as follows:
---------------------------------------------------------------------------------------

-- Head --
Stacktrace:
at azd.Z(MinecraftOverlay.java:463)

-- Initialization --
Details:
Stacktrace:
at azd.e(MinecraftOverlay.java:689)
at net.minecraft.client.main.Main.main(SourceFile:103)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at net.minecraft.launchwrapper.Launch.launch(Launch.java:134)
at net.minecraft.launchwrapper.Launch.main(Launch.java:28)

-- System Details --
Details:
Minecraft Version: 1.7.2
Operating System: Windows 8.1 (amd64) version 6.3
Java Version: 1.7.0_60, Oracle Corporation
Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
Memory: 62123048 bytes (59 MB) / 228589568 bytes (218 MB) up to 954728448 bytes (910 MB)
JVM Flags: 2 total; -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump -Xmx1G
Mod Pack: Unknown / None
LiteLoader Mods: none
LaunchWrapper: 12 active transformer(s)
- Transformer: com.mumfrey.liteloader.launch.LiteLoaderTransformer
- Transformer: com.mumfrey.liteloader.core.transformers.CrashReportTransformer
- Transformer: optifine.OptiFineClassTransformer
- Transformer: com.mumfrey.liteloader.core.transformers.LiteLoaderCallbackInjectionTransformer
- Transformer: com.mumfrey.liteloader.core.transformers.ChatPacketTransformer
- Transformer: com.mumfrey.liteloader.core.transformers.ServerCustomPayloadPacketTransformer
- Transformer: com.mumfrey.liteloader.core.transformers.ServerChatPacketTransformer
- Transformer: net.eq2online.macros.transformers.CollectionPacketTransformer
- Transformer: com.mumfrey.liteloader.core.transformers.JoinGamePacketTransformer
- Transformer: com.mumfrey.liteloader.core.transformers.MinecraftOverlayTransformer
- Transformer: com.mumfrey.liteloader.core.transformers.LoginSuccessPacketTransformer
- Transformer: com.mumfrey.liteloader.core.transformers.CustomPayloadPacketTransformer
AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
Launched Version: 1.7.2
LWJGL: 2.9.0
OpenGL: AMD Radeon HD 7560D GL version 4.2.12422 Compatibility Profile Context 13.152.1.1000, ATI Technologies Inc.
Is Modded: Very likely; Jar signature invalidated
Type: Client (map_client.txt)
Resource Packs: []
Current Language: English (US)
Profiler Position: N/A (disabled)
Vec3 Pool Size: ~~ERROR~~ NullPointerException: null
Anisotropic Filtering: Off (1)[/spoiler}

EDIT AFTER REALISSING I DIDN'T DELETE META-INF!
WAIT NEVER MIND! IT'S OKAY NOW! Yay!
 
Joined
May 20, 2013
Likes
2
#46
Like several others it seems I'm having issues with 1.7.10 Rei's. No errors but it doesn't load. I get that it needs META-inf needs to be deletes. If someone can tell me what minecraft directory it needs to be installed on that would point me in the right direction. Thanks
 

Jrr_

Architect
Balance Team
Adventure Team
Tier 3
Joined
Oct 27, 2012
Likes
150
Location
Straya
#47
Like several others it seems I'm having issues with 1.7.10 Rei's. No errors but it doesn't load. I get that it needs META-inf needs to be deletes. If someone can tell me what minecraft directory it needs to be installed on that would point me in the right direction. Thanks
AS the title says this is FOR 1.7.2 NOT 1.7.2 :/
 
Top