• Register so you can experience the greatest RPG server ever! Use the keyword "Herocraft" when registering!Register! Enjoy the server @ play.hc.to !
  • Guest, Make sure to use our LAUNCHER! Read more here!

How To Installing 1.7.2 - Rei's Minimap, Macromod, Liteloader, TABBYCHAT and Optifine

Joined
Nov 19, 2012
Likes
41
Location
Philippines
#21
Ermm... There is a JVM argument needed to be typed in, in order to possibly fix that:

-Dfml.ignorePatchDiscrepancies=true

Do "Edit Profile", then copy-paste the argument above to the "JVM arguments" box
 
Joined
Dec 19, 2012
Likes
33
#22
Ermm... There is a JVM argument needed to be typed in, in order to possibly fix that:

-Dfml.ignorePatchDiscrepancies=true

Do "Edit Profile", then copy-paste the argument above to the "JVM arguments" box
Interesting. I haven't personally tried that, as I've found no particular reason to use forge as of yet. That'll be handy to have around should we ever need to use forge to load any approved mods.
 
Joined
Nov 19, 2012
Likes
41
Location
Philippines
#23
Forge somehow just doesn't let Minecraft run if there's a discrepancy. That argument bypasses that kind of check and lets MC run with the mods that are causing the discrepancy.
 
Joined
Jan 6, 2014
Likes
65
Location
uremom
#27
Ok, so i decided to try this again, only this time i got a factory reset on minecraft (so its all 100% cleaan) i did every single step just as you said and everything worked just fine, but when i launched minecraft after all steps were done, the launcher froze for a second, then launched minecraft as 1.7.9 and no mods are there.... ill try everything again but this really sucks D:
 
Joined
Jan 6, 2014
Likes
65
Location
uremom
#28
Ok, so i decided to try this again, only this time i got a factory reset on minecraft (so its all 100% cleaan) i did every single step just as you said and everything worked just fine, but when i launched minecraft after all steps were done, the launcher froze for a second, then launched minecraft as 1.7.9 and no mods are there.... ill try everything again but this really sucks D:
So everything was working, but then i guess somehow getting rei's fucked it up D:
 
Joined
Jan 6, 2014
Likes
65
Location
uremom
#29
Now ive been trying to get just macro's and optifine working, and cant even do that D:

Ive reset my minecraft to factory version and started all over multiple times and no luck, i get liteloader just fine, then when i do the steps to get macros there just shows no mods...
 
Joined
Nov 19, 2012
Likes
41
Location
Philippines
#31
I finally traced my problem with the random disconnecting!
It's Macro Mod! I don't know how, but I traced it down by following your instructions, ran LiteLoader, no problems. Ran it after installing MacroMod, boom, actually disconnecting when I log into the server now...

If I remove Macro Mod from the 'mods' folder, leaving LiteLoader only, it'll work like new again. There must be something in Macro Mod's code that's interfering with the connection or something... I don't know...
 
Joined
Jan 6, 2014
Likes
65
Location
uremom
#32
I finally traced my problem with the random disconnecting!
It's Macro Mod! I don't know how, but I traced it down by following your instructions, ran LiteLoader, no problems. Ran it after installing MacroMod, boom, actually disconnecting when I log into the server now...

If I remove Macro Mod from the 'mods' folder, leaving LiteLoader only, it'll work like new again. There must be something in Macro Mod's code that's interfering with the connection or something... I don't know...
I did everything he did and it worked, only time I get dc'ed is when my internet goes out, otherwise it's the server.


For me at least.
 
Joined
Nov 19, 2012
Likes
41
Location
Philippines
#33
@CoolBeans279 It's either I need better internet (30-50kbps actual average, average 280 ping to HC, promised 1Mbps internet), or Ubuntu Linux, but I'm ultra-confident it's Macro Mod 'cause when I had Macro Mod in 1.6.4's time (when I actually joined HC), The only times I'd get disconnected are when my internet is down, or server-side problems.
 
Joined
Jan 6, 2014
Likes
65
Location
uremom
#34
@CoolBeans279 It's either I need better internet (30-50kbps actual average, average 280 ping to HC, promised 1Mbps internet), or Ubuntu Linux, but I'm ultra-confident it's Macro Mod 'cause when I had Macro Mod in 1.6.4's time (when I actually joined HC), The only times I'd get disconnected are when my internet is down, or server-side problems.
Idk m8, i have 4 mb internet in a third world county, ping is about 150, in the US i get 25mb internet and about 50 ping, wouldnt know if its ping/internet D:
 
Joined
Apr 6, 2014
Likes
4
Location
Hong Kong, China
#36
This shouldn't be necessary. The Optifine jar files are autoinstallers. I recommend first downloading and installing Optifine by simply executing the jar, and then installing LiteLoader. When you install LiteLoader, check the "chain to OptiFine" checkbox. Rei's minimap does have to be installed manually.
^^ This helped me a lot. I tried the other method 10 times but it never worked.

*Mac User*
 
Joined
Nov 19, 2012
Likes
41
Location
Philippines
#37
<---- Ubuntu Linux user, prolly the only one too...
I just want some coder or programmer to examine the macro mod .litemod file to see if there are any files related to connecting/disconnecting and that if they are important or not, 'cause Macro/Keybind mod is what's causing my disconnection and inability to join Shrine/Haven (and sometimes the Hub)...

I'm upgrading my internet next month so I hope that'll fix it and alleviate some internet-wise lag.
 
Joined
May 24, 2014
Likes
0
#39
ADDED: Please use this link for Winrar (Windows) if you don't already have it: http://download.cnet.com/WinRAR-32-bit/3000-2250_4-10007677.html

Mac Users: You're default unzipping/unarchiving program should work, if not, use Unarchiver.


This thread is for those who seem to have endless issues installing the aforementioned mods.

If you follow the following steps, you'll have Minecraft 1.7.2 running Rei's Minimap, Macromod, Liteloader, and Optifine:

1) Download a fresh copy of Minecraft 1.7.2. (You do this in the Minecraft Launcher by adjusting the options for the version.)
2) Run Minecraft, then close it.
3) Install the Liteloader Mod located here (Be sure to use the latest release.): http://www.minecraftforum.net/topic/1868280-172api-liteloader-for-minecraft-172/ To install, just doubleclick the .exe or .jar to install just like any other program.
4) Run Minecraft with the Liteloader profile (when you run it, you should see the Liteloader tab on the launch screen), then close it.
5) Place the Macromod file into the 'Mods\1.7.2' folder. The download is located here (Be sure to use the latest release.): http://www.minecraftforum.net/topic/467504-172-macro-keybind-mod-01002-beta-release/
5a) Run Minecraft and choose the Liteloader profile in the profiles dropdown before clicking play.
6) Click play (when you run it, Macromod will open a config screen), then close it.
7) Using Winrar, open the Optifine .jar located here (get the latest 1.7.2 version): http://optifine.net/downloads.php
8) Also open your Liteloader version .jar with Winrar from your .minecraft/versions folder.
9) Copy the Optifine .jar contents into the 1.7.2 Liteloader .jar file.
10) Using Winrar, open the Rei's Minimap .zip located here (get the latest 1.7.2 version): http://www.games-utilities.com/reis-minimap-mod-minecraft-1-4-4/
11) Copy the Rei's Minimap .jar contents into the 1.7.2 Liteloader .jar file.

I've not found a proper way to install Rei's for Mac, so if anyone figures that out and can post instructions or a link, that would be helpful.

12) In the 1.7.2 Liteloader .jar file, delete the META-INF folder.
13) You should now be happily running Minecraft 1.7.2 (be sure you choose to run it with the Liteloader profile.)

I hope this clears confusion and assists people in getting their Mods up and running.

Heromod will be updated soon as well, so keep your eye out for that.

UPDATE: TabbyChat is now updated to 1.7.2

It is available at http://www.mediafire.com/download/3vvo7k1i4f48age/TabbyChat-1.11.0-pr-all.zip
You're in for a treat! Installation is as simple as unzipping the archive, and placing the .litemod file in the \mods folder of your .minecraft version. (DriveLetter:\Users\YourUsername\AppData\Roaming\.minecraft\mods)

Mac users should be able to work out how to install this as well (place in your \mods\1.7.2 directory.

ENJOY!
(Note: As of now, item links do NOT work with TabbyChat...or at least I couldn't find a way to make them.)

NEW UPDATE: WorldEditCUI is available here: http://www.minecraftforum.net/topic/2171206-172-worldeditcui/

I'll be updating the Wiki for Subregions soon!
How do I open the liteloader.jar file? Do I right click the folder itself or the content inside it?
 
Joined
May 24, 2014
Likes
0
#40
ADDED: Please use this link for Winrar (Windows) if you don't already have it: http://download.cnet.com/WinRAR-32-bit/3000-2250_4-10007677.html

Mac Users: You're default unzipping/unarchiving program should work, if not, use Unarchiver.


This thread is for those who seem to have endless issues installing the aforementioned mods.

If you follow the following steps, you'll have Minecraft 1.7.2 running Rei's Minimap, Macromod, Liteloader, and Optifine:

1) Download a fresh copy of Minecraft 1.7.2. (You do this in the Minecraft Launcher by adjusting the options for the version.)
2) Run Minecraft, then close it.
3) Install the Liteloader Mod located here (Be sure to use the latest release.): http://www.minecraftforum.net/topic/1868280-172api-liteloader-for-minecraft-172/ To install, just doubleclick the .exe or .jar to install just like any other program.
4) Run Minecraft with the Liteloader profile (when you run it, you should see the Liteloader tab on the launch screen), then close it.
5) Place the Macromod file into the 'Mods\1.7.2' folder. The download is located here (Be sure to use the latest release.): http://www.minecraftforum.net/topic/467504-172-macro-keybind-mod-01002-beta-release/
5a) Run Minecraft and choose the Liteloader profile in the profiles dropdown before clicking play.
6) Click play (when you run it, Macromod will open a config screen), then close it.
7) Using Winrar, open the Optifine .jar located here (get the latest 1.7.2 version): http://optifine.net/downloads.php
8) Also open your Liteloader version .jar with Winrar from your .minecraft/versions folder.
9) Copy the Optifine .jar contents into the 1.7.2 Liteloader .jar file.
10) Using Winrar, open the Rei's Minimap .zip located here (get the latest 1.7.2 version): http://www.games-utilities.com/reis-minimap-mod-minecraft-1-4-4/
11) Copy the Rei's Minimap .jar contents into the 1.7.2 Liteloader .jar file.

I've not found a proper way to install Rei's for Mac, so if anyone figures that out and can post instructions or a link, that would be helpful.

12) In the 1.7.2 Liteloader .jar file, delete the META-INF folder.
13) You should now be happily running Minecraft 1.7.2 (be sure you choose to run it with the Liteloader profile.)

I hope this clears confusion and assists people in getting their Mods up and running.

Heromod will be updated soon as well, so keep your eye out for that.

UPDATE: TabbyChat is now updated to 1.7.2

It is available at http://www.mediafire.com/download/3vvo7k1i4f48age/TabbyChat-1.11.0-pr-all.zip
You're in for a treat! Installation is as simple as unzipping the archive, and placing the .litemod file in the \mods folder of your .minecraft version. (DriveLetter:\Users\YourUsername\AppData\Roaming\.minecraft\mods)

Mac users should be able to work out how to install this as well (place in your \mods\1.7.2 directory.

ENJOY!
(Note: As of now, item links do NOT work with TabbyChat...or at least I couldn't find a way to make them.)

NEW UPDATE: WorldEditCUI is available here: http://www.minecraftforum.net/topic/2171206-172-worldeditcui/

I'll be updating the Wiki for Subregions soon!
When I play with the liteloader version my mod won't load and it's rei minimap
 
Top